Results 1 to 7 of 7

Thread: Resurrection pings

  1. #1
    Join Date
    Apr 2014
    Location
    Northern California
    Posts
    67

    Resurrection pings

    Anyone know how to stop the pinging in my tank when I shoot the resurrection? It only happens when the bolt return when firing

  2. #2
    Join Date
    Dec 2017
    Posts
    46
    Are you certain the pinging is from the tank? That shouldn't be any issue when the bolt returns to its forward position.

    On the other hand, Resurrections do tend to have a very distinctive bell-like ringing sound during cycling, particularly as the bolt goes forward (as you've noted). Just check out some YouTube videos of them shooting, and you'll hear it loud and clear.

    My guess is that it has to do with the fact that they have been heavily milled to save weight and the metal is very thin in certain places. These thin-walled areas in turn may resonate during cycling, producing that distinctive sound.

    Just a guess.

  3. #3
    Join Date
    Nov 2016
    Posts
    40
    funny I cam across this thread. I just picked up a ressy and it pings too.. I have shot another one a few weeks ago and it was almost as quiet as my 2k (action wise). So I think it just may be how it is set up. I searched a little and I have seen a few threads that they changed this or that and all of a sudden the ping went away but no one definitely claims they know what fixes it.

    Gonna tinker a little and see what I can figure out.

  4. #4
    Join Date
    Nov 2016
    Posts
    40
    I figured out my ping issue. looks like the PO had the sled adjusted so that it was hitting the body when it closed. Backed the sled off the body about as much as I would a normal back block and she is quiet now.

  5. #5
    Join Date
    Dec 2017
    Posts
    46
    Makes sense!

  6. #6
    Join Date
    Apr 2014
    Location
    Northern California
    Posts
    67
    Not only did it make sense,it removed the ping. well most of it. There is still a light ping but it has nothing to do with cycling with air, your idea SC Thumper fixed that(thank you, it was very irritating).
    For the remainder of the ping, the trigger frame is the culprit. when I have the marker degassed and the tank off it still has a slight ping when i pull and release the trigger. I do have to say, it is slight and hardly noticable. My guess it's the way Simon designed the internals so the trigger is snappy rather than a smooth pull. Maybe i will try a lighter spring set for a smoother action.
    Last edited by shockler; 07-27-2018 at 11:27 PM.

  7. #7
    Join Date
    Nov 2016
    Posts
    40
    Quote Originally Posted by shockler View Post
    Not only did it make sense,it removed the ping. well most of it. There is still a light ping but it has nothing to do with cycling with air, your idea SC Thumper fixed that(thank you, it was very irritating).
    For the remainder of the ping, the trigger frame is the culprit. when I have the marker degassed and the tank off it still has a slight ping when i pull and release the trigger. I do have to say, it is slight and hardly noticable. My guess it's the way Simon designed the internals so the trigger is snappy rather than a smooth pull. Maybe i will try a lighter spring set for a smoother action.
    I just installed his new sear spring kit as well as the return spring kit. it got rid of the snappy sound and feel. He told me that he also has a new trigger plate coming to make it feel like the old school cocker frames. This I cant wait for.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •