Results 1 to 6 of 6

Thread: Need some Karni help.

  1. #1
    Join Date
    Jan 2011
    Posts
    18

    Need some Karni help.

    Alrighty y'all. First off, hey how's it going? Been years since I've been on here.

    So, I'm working on a Karnivore, I'm a tech at the local field. This is the first time I've had the chance to work on one or any e-framed cocker. It came in leaking from the furthest qev(?) on the ram. I opened it up (I've worked on mech cockers a handful of times) cleaned it out and replaced the o ring. Good feeling this thing hasn't been opened up in a while. Did the same with the LPR and HPR. Now the gun isn't leaking but it doesn't shoot either. I air it up and it acts like air isn't getting past the LPR.

    I can tell a little bit is because if I manually cock it and pull the trigger there will be a little pop of air when the hammer hits the valve. I've tried adjusting the HPR and LPR, nothing seems to change.

    When I turn the asa off the reg holds air. I then manually cock it and release the hammer until all air is out of the reg. Now, when it gets down to the last 2 or 3 "shots" of air it will try to shoot like normal. Start to push the ram back and even recock itself. It'll do that once or twice then be out of air.

    As I'm writing this out, it's sounding more and more like a solenoid problem. I will tear that down and take a look. Unless y'all got something else I can look into.

    I'll tear down the LPR and HPR and show how all the pistons, shims and such look. Maybe I'm just dumb and put something back together wrong.

    Shims are as follows.

    Piston )()()()


    https://drive.google.com/folderview?...yXCHphoKi-d2n_
    Last edited by xxxpbfrkxxx; 10-13-2021 at 10:44 PM.

  2. #2
    Join Date
    Nov 2006
    Location
    New Jersey
    Posts
    2,883
    for starters take a look at the hpr and the lpr reg seat. If you have a reg tester see what pressure the hpr is set at. I'm thinking you may be over-pressuring the gun. Once you know you have a good hpr and have it set to about 325-350 then air up an pull the hose off of the lpr and confirm you are getting air out of it...

  3. #3
    Join Date
    Jan 2011
    Posts
    18
    Hella late response from me. I appreciate the suggestion. I'll look into that. Thanks!

  4. #4
    Join Date
    Feb 2008
    Location
    Jackson, CA
    Posts
    2,757
    The Small black oring looks in your photo to be the wrong size it should be a -008 70d.

  5. #5
    Join Date
    Jan 2011
    Posts
    18
    Assuming you're talking about the HPR, I changed it to an Eclipse 008 NBR70. I feel that is probably the same thing. The reg seats do look a bit worse for wear. Is there another brand (current dye, eclipse, etc) that uses the same? It's like pulling teeth to get my manager to order parts that aren't direct from manufacturer.

  6. #6
    Join Date
    Nov 2006
    Location
    New Jersey
    Posts
    2,883
    PM docfire who posted above as he has replacement hpr seats. and last I checked you can get replacement reg seats for the lpr from autocockerparts.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •